Jump to content


Become a part of the community today! Registration is quick and easy and will enable you to post, send personal messages, and join in on the chat! It's as simple as clicking on the links above.

Want to submit, but submition not works


  • Please log in to reply
5 replies to this topic

#1 arestov

arestov

    New User

  • Members
  • Pip
  • 4 posts

Posted 17 April 2012 - 05:59 AM

I have ready to submition app http://dl.dropbox.co...216/seesu.btapp (http://seesu.me , http://seesu.me/o)

http://img-fotki.yan...1_dac31963_orig


But I can not submit because this error:
gleb@Gleb-PC /cygdrive/d/_Documents/making/sa/d/btapp
$ apps  submit
running `generate` ...
        updating project metadata
        creating index.html
running `package` ...
running `submit` ...
Traceback (most recent call last):
  File "apps-sdk.py", line 9, in <module>
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 227, in run
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 168, in run_commands
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 178, in run_command
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\command\submit.py", line 25, in run
NameError: global name 'logging' is not defined

Also "apps" creating Seesu.btapp zip file with 1MB size, dummy index.html and folders inside. Why!? I do not need this.
I've created own zip file (http://dl.dropbox.co...216/seesu.btapp) with my own index.html and js structure. And 300KB size. How I can submit it?
Why apps submition is so hard?

#2 Harold Feit

Harold Feit

    Community Manager

  • Administrators
  • 4,611 posts

Posted 17 April 2012 - 12:52 PM

That looks like the code is incomplete.

#3 arestov

arestov

    New User

  • Members
  • Pip
  • 4 posts

Posted 21 April 2012 - 07:47 AM

That looks like the code is incomplete.

I make changes in package to satisfy all SDK requests
http://dl.dropbox.co...SeesuPack.btapp

but get
D:\_Documents\seesu>apps submit
running `generate` ...
        updating project metadata
        creating index.html
running `package` ...
running `submit` ...
Traceback (most recent call last):
  File "apps-sdk.py", line 9, in <module>
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 227, in run
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 168, in run_commands
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\vanguard.py", line 178, in run_command
  File "c:\program files (x86)\apps-sdk\apps_sdk-0.2.4-py2.6.egg\apps\command\submit.py", line 25, in run
NameError: global name 'logging' is not defined

how i can submit my app?

#4 arestov

arestov

    New User

  • Members
  • Pip
  • 4 posts

Posted 22 April 2012 - 01:01 PM

I install "bt-apps" in unix env of cygwin, and gets following errors:

$ apps submit
Scanning acceleration disabled (_speedups not found)!
running `generate` ...
        updating project metadata
        creating index.html
running `package` ...
running `submit` ...
Traceback (most recent call last):
  File "/usr/bin/apps", line 8, in <module>
    load_entry_point('apps-sdk==0.5', 'console_scripts', 'apps')()
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 241, in run
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 177, in run_commands
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 189, in run_command
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/command/submit.py", line 24, in run
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1544, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1294, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1236, in _conn_request
    raise ServerNotFoundError("Unable to find the server at %s" % conn.host)
httplib2.ServerNotFoundError: Unable to find the server at ec2-184-73-13-122.compute-1.amazonaws.com

gleb@Gleb-PC /cygdrive/d/_Documents/seesu
$ apps submit
Scanning acceleration disabled (_speedups not found)!
running `generate` ...
        updating project metadata
        creating index.html
running `package` ...
running `submit` ...
Traceback (most recent call last):
  File "/usr/bin/apps", line 8, in <module>
    load_entry_point('apps-sdk==0.5', 'console_scripts', 'apps')()
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 241, in run
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 177, in run_commands
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/vanguard.py", line 189, in run_command
  File "build/bdist.cygwin-1.7.11-i686/egg/apps/command/submit.py", line 24, in run
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1544, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1294, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 1268, in _conn_request
    conn.connect()
  File "/usr/lib/python2.6/site-packages/httplib2-0.7.4-py2.6.egg/httplib2/__init__.py", line 890, in connect
    raise socket.error, msg
socket.error: [Errno 116] Connection timed out


#5 arestov

arestov

    New User

  • Members
  • Pip
  • 4 posts

Posted 27 April 2012 - 12:23 PM

Can someone help me? :(((

#6 Guest_c0ax_*

Guest_c0ax_*
  • Guests

Posted 06 July 2012 - 03:12 AM

Can someone help me? :(((


I feel your pain dude! I also just tried to submit my app to bittorrent and failed, and this is what I discovered...:

I had to deal with 3 problems before my app would submit:

1). My firewall was blocking submit. submit tries to send an email and my firewall was automatically blocking them.

2). I was missing parameters when running apps submit.

3). The default address submit is trying to send to (thomas@bittorrent.com) doesn't work/exist anymore!

Here's what I did:

1). I ran cygwin in administrator mode (right click "run as administrator")

2). I switched my stupid firewall to: off.

3). I ran app submit with the following commands:

> apps submit --user="Your or company name" --rcpt=root@bittorrent.com

Note:

Ultimately, I don't if this is going work, because does anybody at bittorrent check the root email account?!