Recommended Posts

Hello,

I have recently switched ISP from Talk Talk to Plusnet and I've had an issue since.

 

As soon as I start the program the download speed goes up to 1.8MB/s then drops after 30 seconds to ~200-300kb/s.

 

The only way for the speeds to return to normal is if I manually change ports within the program the speed shoots back up then drops again after about 30 seconds.

 

I've forwarded the ports in my router and allowed the program and ports to my firewall so I'm at a loss as to why I'm having to manually change ports every 30 seconds when the speed is obviously there, I've spoken to my ISP and they told me they do not throttle anymore so that is not the issue.

 

Hopefully you guys have some helpful tips and answers I could try, thanks in advance.

Share this post


Link to post
Share on other sites

No messages in the bar, it's green tick and says everything is working as it should.

 

I've just downloaded from that link and it downloaded with no problems at a constant between 1.2 - 1.7MB/s

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this