Jump to content

no incoming connection/connecting to peers


Recommended Posts

So, I have torrented for quite some time now. I usually used my dell studio 1500 with windows 7. However, I recently bought a new laptop, a lenovo ideapad y500 with windows 8. I tried using bittorrent, utorrent, even vuze and it will not work. It let me download civilizations 5 and then nothing after that. It always says, connecting to peers and never changes, and indicates a yellow "no incoming connection" in the bottom right corner. I pick the torrents with the most amount of seeders/peers usually. I have tried disabling/enabling UPnP ports, enabling/disabling NAT-PNP. I tried randomizing versus not randomizing ports. I tried changing my ports between the range of 30,000 and 60,000. I added a firewall exception for bit torrent. I even uninstalled my mcafee software and disabled my windows firewall to see if that was the problem. After all that, I even went into windows firewall and it clearly says ALLOWED for utorrent for the inbound rules. My internet connection is fine. I tried the setup guide and it says my port forward is open and configurations are fine. I have no idea why this is not working. Is it because of windows 8? I would appreciate any type of response because I am dying here. Thanks.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...