Jump to content

Stuck On "finding Peers"?


Recommended Posts





I was previously using uTorrent and for the past few years it didn't give me any problems then out of the blue just 2 days ago when I started a new torrent the status have been stuck on "Finding Peers". Then many of my other completed and seeding torrents. which were originally green bars, turned red.


Today I unistalled uTorrent and installed BitTorrent instead and I still have the same problem. I've tried different torrents, but to no avail. I even tried other torrent clients but they have to same problem. (EDIT: I have looked at other articles regarding the same problem but no solid solutions was provided in the threads.)


On my tracker tab, DHT, Local Peer Discovery and Peer Exchange are all working, but for the others it says connection time out. I'm currently using Norton for my Anti-Virus.


Any help would be appreciated! 


(EDIT: Now the status bar changed from "Finding Peers" to "Connecting To Peers" but it's still stuck )': )

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...