Jump to content

Bittorrent Try To Use Upnp Even When Nat-Pmp Worked. Is It Normal?


Recommended Posts

Hi! I'm really confused... I talked about this issue in the General Discussion board, but I know it is better to talk about it here. I uninstalled Bittorrent because I thought it couldn't handle my Apple's router.


I'll show you some log entries I received:


[00:00:04]  UPnP: Could not map UPnP Port on this pass, retrying.

[00:00:06]  UPnP: No cached host.  Returning false from CheckCachedUpnpHost()

[00:00:06]  UPnP: The device "" is not a UPnP router (http://**********/)

[00:00:11]  DEBUG: UPnP: Not replying to Service Type [upnp:rootdevice]

[00:00:14]  UPnP: Could not map UPnP Port on this pass, retrying.


I thought Bittorrent was trash but then I noticed it managed to work with NAT-PMP immediately:


[00:00:01]  NAT-PMP: Mapped TCP port ***** -> **********

[00:00:01]  NAT-PMP: Mapped UDP port ***** -> **********

[00:00:01]  NAT-PMP: Got external IP: ***********


So... Why Bittorrent is still trying to use UPnP when NAT-PMP worked?


All my quotes are from the same session.


When I saw entries like the one in the first quote, I switched back to my old client which was working like a charm, but if Bittorrent works also, then I might come back to it.


Could you explain to me why Bittorrent keeps trying to use UPnP?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...