Jump to content

Bittorrent Client For Mac (Version 7.4.3 (37980)) Blank Screen.


Recommended Posts

I can say that BT works with no issue on Yosemite for me.


You don't mention what OS you're using but if a full system restart doesn't resolve the issue I would delete the plist files first.

First ensure that Bittorrent is shut down and NOT running.


Then hold down the Option key while clicking the "Go" menu item in Finder. You will see the Library folder in the drop down. Select that and then go to the Preferences folder. Inside that folder move any files with "com.bittorrent.BitTorrent.plist" to the desktop. There will normally only be one but if there's more than one move those too. Restart BT and see if the issue is resolved. If it isn't resolved you can place the plist files back into the preferences folder replacing the newly created ones when BT was relaunched. We will now go after the cache files.

Go back to the Library folder and then into the Caches folder move any folder you see that refer to Bittorrent. Specifically com.bittorrent.BitTorrent. Remove the folder with this name and restart BT again. If the issue is still not resolved I would make sure that Hard Drives where you're saving your torrent files is accessible to the system. If none of these things work I would consider deleting BT and redownload/reinstall.

Link to comment
Share on other sites

I have the same issue.


Bittorrent starts up, but doesn't open the main window.

If I use CMD-1, it opens the main window, but doesn't show any data (same as for jvhaarst above).

I cannot add torrents; if I use Add, I can choose a file, but nothing happens after clicking OK. If I choose Add URL, it doesn't respond after clicking OK and BT will just crash if I click OK or Cancel repeatedly.


I have 2 Macs running BT (not simultaneously), same issue on both.

Tried system restart to no avail.

Tried clearing the prefs and caches to no avail.

Tried re-installing to no avail.


1 Mac OS X 10.10.2, BT 7.4.3

2 Mac OS X 10.10.1, BT 7.4.3


It was working fine until a few days ago.

Link to comment
Share on other sites

I have same problem, BT not working.


I did everything invadingrobots and knaapie say, and nothing.


I am not very sistems savvy, but noticed that in BitTorrent/window/messagelog there are 3 messages that say:


"file not found during integrity check, users/library/applicationsupport/bittorrent/remote-devpair.dat"  another with "...devpair.dat.new" and another with "...devpair.dat.old" 


I dont know if this can be the problem... these files are not in that folder


Bittorrent was working fine 2 days ago in the same mac.


Please help

Link to comment
Share on other sites

I resolved this on my systems.


What I did...

- Removed Bittorrent from the Applications folder

- Removed the folder /Users/<Your User ID>/Library/Application Support/Bittorrent

- Removed the file /Users/<Your User ID>/Library/Preferences/com.bittorrent.BitTorrent.plist

- Emptied the Trash (just to be sure)

- Restarted the system

- Installed the latest version 7.4.3 of Bittorrent from bittorrent.com


Good luck trying this on your system.

Link to comment
Share on other sites

Ehm, I was a bit too fast, the issue is not completely resolved yet.


Every time I restart my system, Bittorrent shows the same issue.

I can resolve it with the following steps;

Remove Bittorrent from the Applications folder

- Remove the folder /Users/<Your User ID>/Library/Application Support/Bittorrent

- Remove the file /Users/<Your User ID>/Library/Preferences/com.bittorrent.BitTorrent.plist

- Install Bittorrent

- Start Bittorrent

- Quit Bittorrent

- Go to Trash and Put Back both the Application Support folder for Bittorrent and the Preferences file

- Start Bittorrent

After this, Bittorrent works again and all previously running torrents are visible.


So, a workaround, but I would appreciate if someone has a tip about why this is happening in the first place.....

Link to comment
Share on other sites

  • 2 weeks later...

Was fiddling around with this today.

Problems arise after starting a torrent. If I install and do not open a torrent, I can quit and restart BT without BT showing issues.

If I start a torrent, then quit BT, it will not start up properly.


Anyone from BT have a clue where to look? I am happy to do some troubleshooting if that helps, but at the moment I don't know where to look.

Link to comment
Share on other sites

  • 2 weeks later...

This issue persists. I was able to "fix" the issue by following Knaapie's steps (thanks again), however issue returns when I relaunch bit torrent. I noticed that if I hit cmd-1 repeatedly (the hotkey for show main window) it will populate more data each time I hit it. This leads me to think that something on my rig is slowing down the java interface from loading/displaying properly. I have the eclipse workspace installed, but little else that would mess with BT (i think). I am not sure there will be any answers to this problem, but my fingers are crossed we can somehow solve it on our own. It really is annoying. 


I have since, been clicking on magnet links, using cmd-u to open the "Open URL" window, pasting the magnet link in and OKing the rest. Otherwise, the most clicking a magnet link will do is launch bit torrent, but it will not add the torrent to the queue.


thanks for listening.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...