Jump to content

[Solved] Cannot Connect To Any Udp Trackers


Recommended Posts

Hi gang.

This isn't a specific BitTorrent problem, as it is affecting any torrent program I try, but I am asking for help here as I literally do not know what else to try.


I've been torrenting just fine for years, but the other day I accidentally forgot to untick one of those great "here's a bunch of bloatware" offers when installing something - needless to say, my PC got hit pretty bad, but I managed to get things working again. I ran Malwarebytes, HitMan and AdwCleaner to get rid of the really nasty ones. At one point I did have to go into my Internet settings and untick "use a proxy for your LAN" to allow me access to the internet again, but since cleaning up the last of the pups I was able to tick it again and my internet still works just fine.


The problem is, since yesterday, I am 100% unable to connect to any UDP trackers on any torrents. I am always getting "Connection timed out" errors.


A few bits of info:


  • Before yesterday, all my torrent programs (of which I only ever use one at a time) were set to uPNP, random ports, etc, and they all worked fine.
  • I have since tried setting to a specific, definitely open port, but it still doesn't work.
  • My PC is one of several on our router, and all the others work fine.
  • I have set my PC to DMZ, opened specific ports, tried all that stuff, but nothing makes any difference.
  • I have no Firewall running. I have no anti-vir running. Windows Firewall is off, but I have allowed the specific ports through it regardless.
  • Trackers with HTTP work fine, and I can download from them.
  • I cannot log in to DHT, either. I get "DHT: Waiting to log in"


I feel I'm forgetting a few steps I've tried, so if anyone needs any more info, please let me know. I am sure one of those horrible programs configured something in my internet settings to cause this, but I'm not sure where else to look. Help?

Link to comment
Share on other sites

I have somehow fixed my problem after another restart.


Things I did before this particular restart included:

Downloading Spybot Search & Destroy - it found one malicious installer. Let it do a boot scan.

I also flushed my DNS and resetting my Winsock Protocol (as one of the previous pups infected them).


One (or maybe both) of these things seems to have fixed my problem, as I can now download from UDPs again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...