Jump to content

Problems with permissions/ Bittorrent has apparently disappeared


loneclone
 Share

Recommended Posts

I have been running Bittorent for many years on various PCs, but as of today I have a weird problem.

I noticed after the latest Bittorrent upgrade the other day I started getting asked to assume administrator privileges when I want to delete a torrent. That I can deal with, because the dialogue box offers that as an option, but now the application has become invisible, it seems.

By that I mean that by checking on a torrent website I can see that the Bittorent client is actually running on my PC, but associated process no longer appears in Windows Task Manager.

If I click on a torrent file itself  I get a message that I need an app to open it, but when I try to search for the Bittorent executable file cannot be found through the dialogue boxes.

I tried downloading the Bitoirrent installation executable to see what would happen. It told me I couldn't download it to my usual folder because I don't have permission. I was able to save it to another location, but when I double clicked on it, it suddenly vanished, and I got a message that it can't be found and that I may not have the appropriate permission to access the file.

By searching using Windows Explorer I found a number of instances of bitorrentie.exe, but they appear to be associated with past upgrades, In any case nothing happens when I click on them.

I have been using Bittorrent for many years, so I can only assume this is some kind of bug associated with the upgrade.
 
I have been using PCs since they were still called microcomputers, and have never seen the like before, so I hope someone can help me figure out what is going on. I know permissions problems can be gnarly to disentangle.
 
Link to comment
Share on other sites

One more bit of strangeness -- I remembered that you can right click and run exe files as an Administrator. When I tried another download to the same location I was able to download it to before, it wouldn't let me, but I was able to find another location and download it. When I right clicked -- I am a leftie when I use my mouse -- and told it to Run as an Administrator, it told me I didn't have permission and then the downloaded exe file disappeared.

It occurred to me that normally when I have this Administrator prompt, it is for a situation such as trying to download a new version of a file that is open in an application like Word. That would be why I can't download the exe file to somewhere I have already downloaded to and opened -- presumably it is already there and active, though it doesn't show up in Task Manager.

Weirder and weirder!

I am now going to try a reboot of my laptop to see what happens.

 

Link to comment
Share on other sites

Thanks, but I should have mentioned that   already checked my antivirus apps and it is not on the lists of blocked apps. Alas, since I can now not see the app or exe via Windows, I am unable to add it to the Allowed Apps list.

I guess it is time to switch torrent clients.

BTW, Bittorrent still appears on the list when I bring up the list of apps using Windows Remove Software feature.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...