Jump to content

Windows 8.1 System Freeze (No Memory) On Huge Files


Recommended Posts



There seems to be a bug either in Bittorent (latest) or in Windows 8.1 x64 (all updates).


After starting big torrent (3 files, 102GB combined), some time after download process starts, system starts allocating RAM for holding virtual memory pages for memory-mapped files that were modified and need to be written to disk. It takes about 50 seconds to consume all available RAM.


In the moment when Resource Monitor displays that "Modified Memory" took all available RAM, system nearly hangs. Even if I try to kill bittorent.exe process with TaskManager in the very beginning, it does not quit but continues to write something to the memory mapped files (according to Resource Monitor and Sysinternals RamMap). It takes more time for system to hang, but it hangs anyway.


I haven't tried to download such huge files in W8, so I don't know if it's W8.1 or W8 behavior.

I don't know what rare aspects of Windows Filesystem API are used by bittorent, and even if it's a bug in overlapped I/O in Windows, maybe some workaround needs to be provided. System is AMD based, I haven't tried on Intel.


Other torrent clients seem to work. Slower, but without hangs.

Link to comment
Share on other sites

I have everything by default but upload limit.


I uninstalled bittorent client yesterday and removed settings. Also I removed all antivirus and restored MS Defender). I reinstalled bittorent, set upload limit, added just 1 torrent and could reproduce the system hang several times with default settings. Hence, preallocate is not enabled.


(I am not really happy to test this, as I use MS software raid (it's on different disks, neither system nor download, so it's not related most probably). Software raid resyncs mirror volumes after every unexpected reboot so I don't like pressing hardware reset key. )


The volume I use for downloading is connected to ASMedia builtin SATA controller, but driver is stock Microsoft.


Both Opera torrent and qbittorrent work ok.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...