Sign in to follow this  
NeowinMOD™

Bittorrent Won't Close, Not Even When Used End Process Via Task Manager

Recommended Posts

After the latest 7.9 versions I've had difficulties of closing BitTorrent, these difficulties started after the first 7.9 version, I removed my torrents from BitTorrent window and then I selected File > Exit, but BitTorrent stays open in Task Manager and won't close, I tried to close it via End Process button multiple times but didn't help.

 

I have to restart the whole computer before BitTorrent closes.

 

You should add a feature to BitTorrent which force closes the app when you want.

 

I have Windows 7 x64 SP1.

Share this post


Link to post
Share on other sites

What internet security software do you have installed?

How long are you waiting after trying to close it?

 

ESET Smart Security, BitTorrent is allowed in Firewall and HIPS, I waited around 5 minutes.

Share this post


Link to post
Share on other sites

Hey there NeowinMOD.  I've had the same problem, bittorrent.exe doesn't actually close when closing normally, and using task manager also doesn't actually work.

On top of that, once this happens, computer performance goes down the drain at this point. 

 

What I found is that for some reason it's still stuck trying to complete writes/commits of downloaded info.  In order to let it finish, I basically had to pull the carpet out from under it, and I denied myself access to read/write the target folder.

 

To figure out which file(s) it's stuck on, open task manager, go to the Performance tab, open Resource Monitor.  Go to the Disk tab.  You should see bittorrent.exe there near the top of the list with a ton of read/write activities.  Whatever files it's still trying to commit should be listed in the lower half. 

Once you've figured that out, browse to the file/folder, right click on it, go to properties, the Security tab, hit Edit, and select your user account and click the checkbox to Deny Full Control to yourself. 

You'll need to do that for each one, or at least the parent folder that contains the files. 

 

At that point bittorrent.exe closed properly for me, and the problem went away.

 

Once it's closed proper, go back into the security and uncheck all of the Deny checkboxes for yourself.

Edited by Jeebachu

Share this post


Link to post
Share on other sites

for me it does now show up in the disk menu. 
then i try to open it again and it will open finally, but then it does the whole "program not responding" thing. 

 

i have already uninstalled and re-installed. 

same problem. 

 

SUPER irritated.  :angry:

Share this post


Link to post
Share on other sites

I've had the same problem. Bittorrent didn't close after using "exit", and the proces didn't dissapear from taskmanager after clicking

"end process" multiple times. Appearantly this has something to do with your antivirus. I'm currently using Avast! antivirus.

I disabled my antivirus and tried ending the process again, this time it gave no probems at all. After restarting bittorent the program

did shut down properly after using "exit".

I added an exception to Avast, since then everything seems to be working fine.

 

Hope this helps guys :)

Share this post


Link to post
Share on other sites

I had exactly the same problem, hangs, computer freezing and the process refusing to stop.

 

My last three downloads I moved to another drive and all my problems went away.

 

I was also experiencing similar problems with Adobe CS6; I moved the scratch disk from the same drive I was using for Bittorrent downloads and the problem went away.

 

Conclusion: failing HDD and both programs were unable to write to the disk, thus being unable to flush the cache/buffer, whatever you like to call it in the case of Bittorrent and unable to write to the scratch disk in the case of CS6.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this