Jump to content

Stuck On 'connecting To Peers'


Recommended Posts



So my bit torrent gets stuck on 'connecting to peers' on literally every torrent I try to download. 

I tried uninstalling and re installing the program and that hasn't helped.


I'm not sure it matters but I am in South Korea. It worked for a few hours when I went to Japan last week and then stopped working again. I know China censors and blocks a lot online but I've never heard of Korea blocking anything?


Help would be appreciated, I'm lost without my torrents!





Link to comment
Share on other sites

  • 2 weeks later...

I have this same issue also when I have my VPN on. I normally run a VPN and separate hidden DNS Servers for security. My VPN gives me an ability to have certain URL's not go through it.  But since this is shared file system it is not possible to put an exception in for every peer nor do I want to.  When I turn the VPN off everything works fine.  Any suggestion to be able to run BitTorrent using a VPN without getting stuck on 'Connecting to Peers' The VPN's I use are TunnelBear and Hide MY IP.  I really hate to have to turn my VPN off just to use the program.  Other then this everything works great and I love it.  Thanks in advance for any help or suggestions

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...