Jump to content

Not syncing all files 2 NAS units


Recommended Posts

Hello Sync Community

This is my first post here so bare with me if I am noob on this. OK before I go into details I think it best if I explain my setup I will draw it first:


FreeNAS(3.7TB media)  --->ubuntu 14.04 LTS(btsync owner) --->Internet--->Western Digital EX4(btsync receiver)


I wanted a backup of all my files that keeps up to date so I placed one of my NAS unite(EX4) at my friends house and I run a 250/100Mbit fiber and he uses a 100/10Mbit fiber. All devices runs the latest version of btsync and am baffeled on how bad this program seems to work. Never have I succesfully synced my whole liberary to my friends house. I have tried adding the library 4 times now and it stopped beeing funny the second time. There is around 5600 files and it takes around 10 days for it to complete the sync over the Internet. So please I really need help now because I want this to work!

Attempt 1: Stopped syncing all together after around 50% of the files synced, tried rebooting the devices and reindexing the folder nothing worked. So I reinstalled everything..

Attempt 2: After a couple of days it hanged at "indexing" on the owner machine and could not index new files. Removed the folder and added it again, seemed to work for a while but then hanged again so I reinstalled the Owner node

Attempt 3: Failed like the 1st

Attempt 4: Some how the amount of files the reviceing and owner nodes needed got "out of sync". Now the reveining node reports "Synced" but the Owner node reports "Sending 528 files". I checked the file system on the receving node and it is exactly the 528 files that it is missing..


I don't know what to do now here are some debug logs from receiving node:


[22:21:27]  SF[F715] [5149]: Received request "files"
[22:21:27]  MC[F715] [5149]: processing files message with 565 files
[22:21:28]  ACL[F715]: VerifyFileSignature: failed to verify ed25519 signature, user: 59E087553358D0695544356311912DD5AF2DE5E13209AFB4EFAB0E10672EDAC8
[22:21:28]  MC[F715] [5149]: failed to verify signature of remote file XXXXXXXXXXXXXXXXXXX, aborting
[22:21:28]  assert failed /opt/sync/SyncFolderMergeController.cpp:880
[22:21:28]  SF[F715] [5149]: State sync finished
[22:21:28]  SyncReq[0x41903b88][uTP-TUNNELL] [0000]: cancel 41903B88 - incoming merge
[22:21:28]  SyncReq[0x41903b88][uTP-TCP] [0000]: destroing 41903B88 cbcnt:9 - incoming merge
[22:21:31]  SF[F715]: UpdatePeersStat
[22:21:31]  SF[F715] [5149]: up:0 down:0
[22:21:31]  ScheduledTask: "UpdatePeersStat" invoked: timer, reason:FinishStateSync
[22:21:36]  PC[0x41900c60][0x00000000][XXX:XXX:XXX:XXX:50160:TUNNELL] incoming connection fro


And there is some from the Owner node:


[22:25:37]  MC[F715] [A800]: Local file Series/XXXXXXXXXXX/S4 is newer than remote t:1453770242/1453770201 ot:59351/59182 o:1036DF5B0C3BD36D72249A575BC5732CCA975149/1036DF5B0C3BD36D72249A575BC5732CCA975149
[22:25:37]  MC[F715] [A800]: will send file /Series/The Walking Dead/S4
[22:25:38]  TCPReq[F715] [0000]: eof F8001250 - outgoing merge
[22:25:38]  SF[F715] [A800]: State sync finished
[22:25:38]  TCPReq[F715] [0000]: cancel F8001250 - outgoing merge
[22:25:38]  TCPReq[F715] [0000]: destroing F8001250 cbcnt:10 - outgoing merge
[22:25:40]  LicenseController:
[22:25:40]  HasValidLicense: 0


And it looks like before the Owner node has completely stopped reindexing the filesystem when I add new files. Why does this even happen? All the files are located on one folder on the NAS and the Owner node has FULL access it can even delete files..


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...