Jump to content

trackerless help


Recommended Posts

I'm wondering if I'm making mistakes earlier in my process.  I'm trying to create a new torrent and share it w/o a tracker, using a CentOS 5 Linux server as my initial seed.


maketorrent-console --no_use_tracker --target <myfilename>.notracker.torrent   <myTomcat7Server>:8080   <myfilename>

when that process finished, I check the newly created target file from above by doing this:

/usr/bin/torrentinfo\-console <myfilename>.notracker.torrent
torrentinfo-console 4.4.0 - decode BitTorrent metainfo files
metainfo file.......: <myfilename>.notracker.torrent
info hash...........: c9b7641d50546c68a75299aef4e40984c0744e73
file name...........: <myfilename>
file size...........: 5656731714 (21578 * 262144 + 188482)
trackerless nodes...:
        <myTomcat7Server>   :8080


Would anyone care to comment on what I'm doing so far?

My next step has been to:

Copy the notracker.torrent file to a publically-accessible are of my Tomcat7 server--already configured for x-torrent using this in the web.xml:


Then, the directions in /usr/share/doc/bittorrent\-4.4.0/README.txt state to do this:

6) start a downloader as a resume on the complete file
You have to run a downloader which already has the complete file,
so new downloaders have a place to get it from. Here's an example -

So, I go into the directory in which the media file resides and do this:

/usr/bin/bittorrent\-curses--start_trackerless_client --ip <myTomcat7Server>:8080 --save_as <myfilename>   <myfilename>.notracker.torrent

I get this, after it cycles quickly through the 'downloading' status

| file:     <myfilename>                                                                                                                                                        |
| size:     5,656,731,714 (5 GiB)                                                                                                                                                    |
| dest:     /tmp/<myfilename>                                                                                                                                                     |
| progress: ###### all the way across the screen|
| status:   seeding (100.0%)                                                                                                                                                         |
| dl speed: 0.0 KB/s                                                                                                                                                                 |
| ul speed: 0.0 KB/s                                                                                                                                                                 |
| sharing:  oo  (0.0 MB up / 0.0 MB down)                                                                                                                                            |
| seeds:    0 distributed copies (next: 1:0.0%)                                                                                                                                      |
| peers:    0 seen now                            

Am I on-track so far?  How do I know?  The "dest:" value above has the directory in which my file resides...is that OK?

Once I do this, I launch my Tomcat7 server, copy the link of the notracker file and paste it into my Windows BitTorrent client software...but the client software seems to get stuck in a status of "Connecting to peers".


Any help is appreciated!



Link to comment
Share on other sites

19 hours ago, Harold Feit said:

Your linux version of the client is old and does not support DHT, which is required for trackerless torrents to work

Thank you for the tip--to my dismay I cannot find any Linux software that is command-line based and is recent...any ideas?

Link to comment
Share on other sites

Ok I've downloaded Ubuntu onto a new VM and am trying to use btdownloadcurses to do my initial download, using a tracker (btrack --port 6969 -dfile dstate), for starters. 

btdownloadcurses --url --ip --saveas mytorrentfile.mxf

this give me "download succeeded!", but then immediately this:

error(s): Problem connecting to tracker - HTTP Error 400: Bad Request

When I continue on anyway and try to use Transmission (GUI) to download the .torrent, the Trackers tab indicates the Tracker had 0 seeders and 1 leechers 1 minute ago.

It also says the mytorrentfile.mxf is Downloading from 0 of 0 peers.  So, no activity, it seems.

I can access via the browser and telnet (the Tracker and Tomcat are running on the same machine) ports 8080 and 6969.  The tracker version is 3.4.2 and it says downloading 1/1, all other values are 0.

When does port 6881 come into play?  I can also telnet to that port when I leave the btdownload running.

Finally, when I use the btshowmetainfo mytorrentfile.mxf.torrent, I see that the info hash matches the hash that the tracker shows via the browser.




Link to comment
Share on other sites

1 hour ago, Harold Feit said: should be the announce url you add to the tracker.

port 6881 comes into play in the listening of the client.

What do you mean by adding to the tracker?  Which command am I misusing? 

I created my .torrent by using 'btmakemetafile mytorrentfile.mxf

When I run 'btshowmetainfo' I see the announce url reflected (

thanks again.

Link to comment
Share on other sites

OK, removing the --ip option from the btdownloadcurses seems to have done it!  The initial download worked right away (I'm testing w/a v small file), and then I ran Transmission UI on Ubuntu and the file downloaded w/o a prob...thanks much!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...