Jump to content

Cant open some downloads


Kev China
 Share

Recommended Posts

Hi,  I am new here and also I am not an expert regarding internet or computers like most of you appear to be, so if you do reply can you please do so as simply as possible.

My problem is, each time I download some movies ( such as  “Assassin's Creed 2016 HDRip.x264-FUMmovie”) it is always the same I can never open it, even I do what it says in the Readme Doc (If the movie is not loading then visit the below link and install the missing CODEC for free.

Download Codec: http://updatecodec.placeofentertainment.org/.  ) I have even tried downloading a codec from XVid direct but it still doesn’t work…. This happens a lot when I download from TV Team

Can anyone please advise me ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...