Sign in to follow this  
eb99

Deleting old torrent files in User/AppData/roaming/bittorrent completely corrupted program

Recommended Posts

While trying to reduce the size of my C: drive backup, I found that Bittorrent had been keeping all of the .torrent files I had ever used for downloading since I installed the program eight years ago. They were in User/Appdata/Roaming/Bittorrent. I manually deleted all but the last year of those files, 20k files totalling 1.16Gb. That caused Bittorrent to corrupt unrecoverably, the program disappeared and when I tried to delete in Control Panel, it said it was already deleted. When I tried to reinstall, it got to 47% unpacked and crapped out. I don't understand what has happened here, and I don't see why:

a) Bittorrent keeps the .torrent files after a torrent is deleted

b) Bittorrent totally corrupts if you manually delete old and unneeded .torrent files.

Edited by eb99
Incomplete title

Share this post


Link to post
Share on other sites

1> If you don't specify to remove and delete the .torrent file, that .torrent file will remain.

2> If they aren't loaded in BitTorrent then the old .torrent files being removed won't affect it.

You probably deleted the entire contents of %appdata%\bittorrent which would delete the program, its configuration AND all the .torrent files, not just the .torrent files and configuration like you thought it would.

Share this post


Link to post
Share on other sites

I only deleted what seemed to be the .torrent files, not any of the folders.

I eventually figured out that (breaking the first law of system design) the executable file was mixed in with the data files, and it had been deleted. I copied over the most recent installation file I had into that folder, ran it, and got the option "Newer version installed, do you want to go back to Version 7.9.9?" Since I knew the newer version was gone, I chose 'Yes' and an older version was installed. It did run successfully and picked up all the outstanding torrents. However, when I tried to update, it said no newer version was available. I thought that might be because of the update folders for newer versions, and deleted all beyond the 7.9.9 version, but that didn't make a difference.

Edited by eb99
Clearer answer to question

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this