Jump to content

Can't download


Recommended Posts

Hi, I was wondering if anybody can help me, I can't download anything on bittorrent. The download keeps timing out.

When I go to setup guide to test the network, it gives me the message port is not open. I went to my router settings and forwarded the port following the instructions in the following link http://portforward.com/english/routers/port_forwarding/Telkom/Mega-105WR/BitTorrent.htm to the letter. When I run the network test it still gives me the same message but when I test the

port on http://www.yougetsignal.com/tools/open-ports/ . It says the port is open.

I have made sure bittorrent is on the firewall exceptions as well as my antivirus' exceptions.

I have restarted the router 3 times already and unistalled an reinstalled bittorrent 3 times, but I still get the same error.

I have also installed utorrent, but utorrent also does the same thing.

I have run out of ideas, if anybody can help me I will appreciate it.

Link to comment
Share on other sites

That guide for bittorrent is potentially massively outdated (It's for the 5.x version of bittorrent at the newest)

The steps for uTorrent are closer to what is currently being used.

What internet security software do you have installed?

Who is your internet provider?

Do you perhaps have a link or guide with current steps I can follow ? I am currently using avast antivirus and my internet provider is Telkom.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...