Jump to content

Error: Can't Open .torrent File


Recommended Posts

I have a bunch of finished torrents which I don't keep in their download destination, instead I move them onto discs.

My problem occured when I wanted to move their .torrent files into a different location. When I did so I got this error message in their status box: "Error: Can't open .torrent file: <path>".


I used "Completed" folder as a denstination for the .torrent files. And so when I moved them back into place and restarted bittorrent I still have the same status only to have the Completed status reset for some reason.


As I mentioned I keep the actual data on discs, so I use bittorrent list of torrents to find the files I need by the dates the torrents have finished.


Is that some type of bug? And, how should I relocate .torrent files safely? Thank you.

Link to comment
Share on other sites

That move is directly causing the error.

Once you move the .torrent files back, force a re-check on the torrents that still have the error.

There is no in-program method to tell BitTorrent about the new location of moved .torrent files, only completed/incomplete downloaded data.

Link to comment
Share on other sites

  • 1 month later...

When I reboot my computer though.. I often get files marked as Error: Can't Open Torrent.. and I find their (incomplete) files in the Completed folder. To Remedy, I must move the incompleted fil(s)/folders back to the Incomplete folder and redownload the torrent again (using the Hash as a referance


This sometimes happends to (known) completted files as well which is time consuming to figure out which are which.


Is there a way to prevent this from happening?  (I have changed no settings however I believe there was a recent update to the program)

Link to comment
Share on other sites

  • 2 years later...

Ok, so I've been having this exact problem and I think I may have the solution. It worked immediately for me, so give it a try.


1) Press Windows + R

2) Type in "%appdata%"

3) Look for the BitTorrent Folder

  3.1) You may want to create a copy of this. Just copy paste, but rename it BitTorrent.old or something

4) Delete this folder.

5) Download a fresh installer and reinstall Bittorrent from scratch.

After this, it worked perfectly fine for me. I'd suggest you do a backup though, in case it doesn't work for you.

Beware, though, this is a sort of "Scorched Earth" option, since you'll lose all of your current seeds and .torrent files, though the downloaded files should be fine since they're always in a different directory.

I can't say for sure, but I've had this problem twice, and this is usually what works (though the first time I did this by accident). I've recently noticed, however, that this problem crops up when you have WAY too many active torrents, because this usually happens once my seed count breaks 600. I tried reinstalling before, but without deleting the %appdata% folder, and it would just reload all of my old torrents and the same problem would occur.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...