Jump to content

Stuck Connecting To Peers, 0 Active Torrents


Recommended Posts

I'm running Bittorrent 7.9.2 on Windows 7 64, and ever since I tried to disable the annoying ads (particularly the left hand one that takes up about 1/4 of the window), I have not been able to reliably download anything. After spending a few hours fiddling with settings, I can usually get downloads going again - temporarily. With no repeatable pattern found as yet.


I'm using a random port #, that is port-forwarded through my Linux firewall. Network tests are always good (unless I turn off both uPNP and NAT-PMP). Running Kaspersky Internet Security 2014, and regularly pause protection or exit it to try and get downloads working again, no luck. I have also tried resetting Winsock, last time I tried downloads resumed the second time I rebooted after executing the command, so it may not have been related.


I was going to include details from the Info tab of a test torrent, but it's all 0's except the hash, added date, directory, etc. The trackers tab is also un-enlightening, with that specific torrent showing a working http tracker with plenty of seeds/peers. Others vary, with some hostnames not found (probably shut down), or connections timed out. But they do all appear to have at least one working tracker, with seeds/peers located - but not one single successful connection (staying up), incoming or outgoing. Traffic shows between 0.5-10 KB/s of overhead, no data traffic. I just found the statistics window, which shows 1509 incoming connections since start, 0 outgoing, 1411 handshake, 651 connections, 8 half-open (0 queued). Looks like the client is refusing to accept or make connections.


The ONLY thing working properly at the moment, is the ads. Suspecting that disabling the ads was coded to cripple downloads and make people pay for Pro, I have reset all Advanced options to default (except the gui.show_notorrents_node one, which seems to reset itself to false after I reset it to the default of true), without success. Occasionally while starting up the client I will see an Active torrent (usually a seed), but that will go away within a few minutes. Some of the torrents I currently have at 0 KBps and 0 peers connected, are listed as having over 1000 peers, so it is definitely not a lack of peers to download from. I can add a torrent to qBittorrent and it works perfectly (including on the same port #, if I shutdown Bittorrent first), but lacks one or two features I prefer about Bittorrent.


Any assistance would be appreciated. I would really rather not have to find another torrent client.

Link to comment
Share on other sites


Hi Harold, thanks for your response. I haven't used Slackware in 20-odd years, more of a CentOS guy these days. However, loading torrents for both distributions, neither works (for the most part). I did get downloads working briefly after my initial post - ironically, this occurred after starting up qBitorrent on the same port as Bittorrent (an accident from previous tests). I cannot imagine how this would enable both clients to work - the only scenario I can conceive of, is if Bittorrent had stopped using that port, allowing qBittorrent to start up with it...but that wouldn't explain why Bittorrent proceeded to download. I would have expected qB to give an error trying to bind the port, and crash (or do nothing). Maybe one/both clients simply started making outgoing connections, not caring if incoming failed...


Unfortunately, this once again fits into the category of "fiddle long enough and something will start working" - trying the same thing now, has no effect at all - and still no errors come up. With both clients set to the same port number, and different combinations of uPNP/NAT-PMP, neither client gives an error; qBitorrent always works; Bittorrent is consistently failing (at the moment).


I have been on the receiving end of the odd syn flood recently, which could be related - but Bittorrent fails to make any connections, long after Kaspersky stops warning me of blocked syn floods. And Windows 7 is documented as having built-in syn flood protection, that cannot be disabled (nor tweaked at all apparently)...between the two of them, and the firewall in front, my system should be relatively resilient to those attacks. At least to the point that it doesn't suffer days/weeks later from a long-finished attack...I should have checked the statistics window for the half-open connections figure from the previous attack, but I forgot. Currently it's again <10, 0 queued (from recent restarts).


Any ideas?


PS Zchao, you might be better off starting a new thread, since these problems seem to vary a lot.

Link to comment
Share on other sites

You tried with your internet security software temporarily uninstalled pgnarf?

Good call - uninstalling KIS 14 seemed to get things working again, and KIS 15 doesn't seem to break it (too badly). For anyone else having similar problems, note that "Pause Protection" didn't make any difference, but uninstalling/reinstalling did. Just not sure if it was a bug/flaw in KIS14, as I didn't bother to reinstall the old version.


However, I'm now seeing a different problem, something I saw occasionally before, but didn't pay much attention to as it was rare. Bittorrent's now getting stuck on 100% CPU (on a single core), and completely unresponsive. The only way to get it back is to kill it in Task Manager, then it seems to work ok for a while - I haven't been at my computer often enough to notice how long it takes to freeze up.


I do have a lot of torrents, so I've always had slow performance, but until recently, it would just freeze temporarily, and come back seconds or minutes later (particularly while loading all the torrents on startup). But now, it never seems to recover (I've left it for a day or more without change). The window displays as greyed out, but it looks like it was happily downloading the new CentOS release at 570 KB/s when it hung.

Link to comment
Share on other sites

Try re-downloading from the website

Current build comes out as 39745

I didn't realise the built-in upgrade wouldn't get the latest...but in this case, it made no difference. Seems to run ok for around 30-60 mins (just a guess), then hangs and is totally unresponsive. Any ideas?

Link to comment
Share on other sites

  • 2 weeks later...

Using some trial and error, it looks like one of the torrents I'm downloading is causing this problem. I'm slowly working through stopping/starting various torrents, so try and identify the problem torrent. To clarify, if I stop all the torrents I have downloading, it works just fine - with just the ones I'm most interested in, it works fine. With all of them (a number of which have no seeds, or their trackers closed down, but I'm hoping to pick up someday on a dynamic/peer discovery basis), then it sticks at max CPU as previously described.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...